Field Service

Get Involved. Join the Conversation.

Posts

  • saurabh suman
    ETA Workforce
    Topic posted October 3, 2016 by saurabh sumanRed Ribbon: 250+ Points 
    Title:
    ETA Workforce
    Content:

    Hi All

    Has anyone work with ETAWorkforce app. if yes please let me know the configuration details. i keep getting error unable to connect to TOA

  • saurabh suman
    Outbound Request from OFSC3100%
    Topic posted October 3, 2016 by saurabh sumanRed Ribbon: 250+ Points 
    Title:
    Outbound Request from OFSC
    Content:

    Hi All

    Is there anyway we can capture the request being sent by OFSC to external system when external system notification is triggered by OFSC.

  • Sunil Ainlod
    SOAP get_activity API gives blank responseAnswered2
    Topic posted September 29, 2016 by Sunil AinlodRed Ribbon: 250+ Points 
    Title:
    SOAP get_activity API gives blank response
    Content:

    Hi,

    I am trying to hit get_activity with a valid activity id but still it gives blank response.

    Request:

    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:toa:activity">
       <soapenv:Header/>
       <soapenv:Body>
          <urn:get_activity>
             <user>
                <now>2016-09-29T12:45:31+05:30</now>
                <login>soap</login>
                <company>*******</company>
                <auth_string>7a2f0b4d1d9a595f2e8b2f2e7dbb1d45c3840ad401567b7cdf3cca545fffa3dc</auth_string>
             </user>
             <activity_id>591</activity_id>
          </urn:get_activity>
       </soapenv:Body>
    </soapenv:Envelope>

     

    Response:

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:toa:activity">
       <SOAP-ENV:Body>
          <ns1:get_activity_response>
             <result_code>0</result_code>
             <activity/>
          </ns1:get_activity_response>
       </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>

     

    Regards,

    Sunil

    Version:
    16.2
  • saurabh suman
    SOAP Ui to OFSC14
    Topic posted September 28, 2016 by saurabh sumanRed Ribbon: 250+ Points 
    Title:
    SOAP Ui to OFSC
    Content:

    Hi All

    I am trying to create activity by using soap ui. I am getting the following error
             <result_code>17</result_code>
             <error_msg>Can't create activity: 65574: insert_appointment: The 'workTypeId' mandatory property is not assigned.</error_msg>
     Any clue what is this worTypeId.

  • saurabh suman
    OFSC SalesForce integration6
    Topic posted September 28, 2016 by saurabh sumanRed Ribbon: 250+ Points 
    Title:
    OFSC SalesForce integration
    Content:

    Hi All 

    I am trying to integrate OFSC(16.2) with Salesforce (Point to Point integration).

    1. I created a notification method external system  in OFSC.

    2. Added all the tags to be sent to Salesforcec in the message.

    3. Added the notification to trigger on adding of activity.

    4.once the activity is created trigger happens and status remain in "New"...no error 

  • Sunil Ainlod
    How to generate auth_string tag using SHA2568
    Topic posted September 27, 2016 by Sunil AinlodRed Ribbon: 250+ Points 
    Title:
    How to generate auth_string tag using SHA256
    Content:

    Hello,

    I am generating auth_string using  below procedure:

    SHA256("2016-09-27T19:01:31+0530" + SHA256( "password" + SHA256("soap")))

    soap --> 736BC2D4E0945110E88F7808A4A4D38D3479A0122DE1DE7AC84C920121928480
    password + 736BC2D4E0945110E88F7808A4A4D38D3479A0122DE1DE7AC84C920121928480 --> 0A2B6055D38BB1B58AA3FAB88DDCB974302EEA0E0175B152D2E36319E06A97A6
    2016-09-27T19:01:31+0530 + 0A2B6055D38BB1B58AA3FAB88DDCB974302EEA0E0175B152D2E36319E06A97A6 --> 4DD6D1CA07824B128AA468DA3C89A41287A2BE92A2DDBB41DCEB5B7353378DD5

     

    Final <auth_string> tag will have 4DD6D1CA07824B128AA468DA3C89A41287A2BE92A2DDBB41DCEB5B7353378DD5

     

    Is this correct? If yes still I am getting below error

    <result_code>33</result_code>
    <error_msg>Authentication failed</error_msg>

    Regards,

    Sunil

    Version:
    16.2
  • Umesh Rao
    OFSC SalesForce Integration4
    Topic posted September 27, 2016 by Umesh Rao 
    Title:
    OFSC SalesForce Integration
    Content:

    Hi All

    I am trying to integrate OFSC with SFDC. When i create activity in Salesforce then activity flows into OFSC. However when the activity is updated in OFSC it is not going to Salesforce. Any help in this regard will be appreciated.

    Regards,

    Umesh

  • Umesh Rao
    OFSC Inbound API (SOAP transactions)20
    Topic posted September 27, 2016 by Umesh Rao 
    Title:
    OFSC Inbound API (SOAP transactions)
    Content:

    Hello,

    Does anyone worked on  OFSC Inbound API's (SOAP transactions)? We tried to use OFSC activity WSDL and  create activity through SOAP UI. For some reason its failing with "501 Not Implemented" error.

    Version:
    16.2
  • Hardik Gupta
    Resource WorkZone Mismatch Error9
    Topic posted September 20, 2016 by Hardik GuptaGold Trophy: 10,000+ Points 
    Title:
    Resource WorkZone Mismatch Error
    Content:

    Hi,

    When I try to move activity on Core Manage Interface via drag and drop I am getting "Resource workzone mismatch" error. The 2 resources have the same work zone and location. 

    Under Resource Settings -> Workzone and Resource Settings -> Location I have added the same address details. 

    Also the activity has the same address as the Resource Location.

    OFSC verison is Feb 2016.

    Thanks

    Version:
    Oracle Field Service Cloud
  • Umesh Rao
    'Create Activity' API call from siebel
    Topic posted September 20, 2016 by Umesh Rao 
    Title:
    'Create Activity' API call from siebel
    Content:

    We are in the process of integrating OFSC with siebel application. Objective of this integration is, whenever an Activity is created in siebel the same should be posted into OFSC. When we tried to POST the activity into OFSC we are getting below mentioned error.

    HTTP Request error during 'Submitting Data SendHTTP request': 'Status code - 400'(SBL-EAI-04117)

    By going through several discussion forum, Bad data can be one of the possible root cause for this issue. However, if I use the same API request in 'Post man' and test, its working as expected. 

    Activity GET  API is working fine from siebel. Only POST method is having problem. 

    Is anyone having any idea about the possible root cause of this issue?