Integrations and APIs for Service

Get Involved. Join the Conversation.

Posts

  • Nigel Oliver
    "class not found" when trying ti use...Answered2
    Topic posted June 3, 2019 by Nigel OliverBronze Medal: 1,250+ Points, tagged Connect PHP, Custom Process Models - CPMs 
    Title:
    "class not found" when trying ti use IncidentResponse
    Summary:
    Receving an erro when trying to use class IncidentResponse
    Content:

    Hi All

    I'm trying to create a custom PHP script that updates an incident with a response and sends it out to the customer,  I'm using the example code from the documentation for 18B but when I test the code a I get error "Class 'RightNow\Connect\v1_3\IncidentResponse' not found".

    Here is the code below, am I doing something wrong ?

    Thanks!

    Nigel

    Version:
    18B
    Code Snippet:
  • Stevie Mayhew
    "Header not understood" error message - PHP5
    Topic posted April 22, 2012 by Stevie Mayhew 
    Title:
    "Header not understood" error message - PHP
    Content:

    Hiya,

    I'm writing a connection API to RightNow in PHP and having a total blast... :D

     

    I've run across an error that I don't understand and can't find any documentation on, or work out what is wrong with my request - Header Not Understood.

    This only happens when I include the ClientInfoHeader as part of the soap request, otherwise I get an error "Data element in the Message is NULL" which is probably due to something else being wrong.

    Any help as to what I'm doing wrong would be fantastic.

     

    Thanks,

    Stevie

    Code Snippet:
  • Kevin Ngo
    "mode=API_MODE_UPDATE, pair 'source_upd' is...Answered7
    Topic posted May 15, 2009 by Kevin NgoRed Ribbon: 250+ Points 
    Title:
    "mode=API_MODE_UPDATE, pair 'source_upd' is required Transaction=[org_update]"
    Content:

    Hi,

    I am able to upload organization data using OF.create(Organization) on a test site. However, when I upload same organization data to our production site, I am getting an error message, "mode=API_MODE_UPDATE, pair 'source_upd' is required Transaction=[org_update]". Please help.

     

    Thanks,

    Kevin

     

     

  • bryan.arndorfer
    "Moving" Contacts to a different OrganizationAnswered4
    Topic posted December 17, 2010 by bryan.arndorfer Bronze Medal: 1,250+ Points 
    Title:
    "Moving" Contacts to a different Organization
    Content:

    I know that the contact_move function is not available in the APIs  at present.  And I know that setting the contacts.org_id = x and calling the contact_update API will not work.

    So we have created a tool that checks the RightNow interface for the contacts that we want to have automatically moved into a specific organization.  It grabs them with all their contact specific information, puts it into variables, and creates a new contact with the organization ID I want.  While it is doing that it deletes the current contact.

    Before it starts to move that contact I first check if it has any Incidents attached.  If it does, then I move them to a temporary location.  Once the new contact is created then I move the Incidents to the new contact ID that was created under the new Organization.

    This process is working great.  

    However, as expected there are some objects that are getting deleted/orpaned with that contact_delete API call.  The one that I am interested in at present is surveys.  I don't see any APIs available in the current version I am working with, to work with the survey(XML can start a campaign), or in Nov 10.  

    Is there any way that I can recreate those surveys, or "move" those surveys to my new Contact ID?

    Interface Version: Nov'09

    Language: C# -- Can switch to accommodate another method

  • Peter Scott
    "ORA-03134: Connections to this server version are no...1
    Topic posted November 21, 2014 by Peter Scott 
    Title:
    "ORA-03134: Connections to this server version are no longer supported."
    Content:

    I am trying to understand why the same C# Oracle access code works under VS2010 environment but not under IIS.

    I am building a web service to access Oracle 9.2 database on the remote machine. The web service must be hosted in the IIS under Windows 2003 machine. The same machine is hosting Oracle 9.2 database.

    The web service must be compiled for x86 CPU because of Windows 2003 that is 32-bit architecture. My Visual Studio project is WCF Application.

    When I run the service under ASP.NET Development Server everything works fine. The database is connected and all CRUD operations are possible.

    When I deploy everything under IIS on my machine or any other machine the I am getting "ORA-03134: Connections to this server version are no longer supported." at the time of connecting.

    I supposed it is some kind of permission problem so I run the service under special Application Pool with LocalSystem account. I even gave to the Oracle client folder installed on my machine Full Control permissions for IIS users but this should not be needed because of LocalSystem account.

    Anyway I tried and nothing. It is always the same error.

    What could be the reason ?

  • rsurujbhLinksys
    "Poor performing query" when searching for...15.0
    Topic posted April 12, 2012 by rsurujbhLinksys Red Ribbon: 250+ Points 
    Title:
    "Poor performing query" when searching for Contacts using Email Address
    Content:

    Hello,
    When executing the following ROQL query using QueryCSV, we are getting the following SOAP error: "Poor performing query - too many rows examined".  Understandable, due to the size of our database.

    ROQL:
    SELECT C.ID FROM Contact C WHERE C.Emails.EmailList.AddressType = 0 AND  C.Emails.EmailList.Address LIKE 'user@domain.com'

    It works fine when using the equals (=) operator.  I am using LIKE to account for case insensitivity.
    Any pointers?

    The idea is to search for/return Contact ID using a contact’s primary email address as the only search criteria.

    Thanks!

    Version:
    Feb 2011 SP2
  • Kurt Helfrich
    "The NameOfSLA ID provided does not correspond with an...10
    Topic posted October 10, 2014 by Kurt HelfrichGold Trophy: 10,000+ Points 
    Title:
    "The NameOfSLA ID provided does not correspond with an active SLA" - but it IS Active!
    Content:

    I'm working on a C# program that creates orgs with SLA instances.  It works most of the time for the hundreds of SLA types we have and orgs that I have created in a cloned testing environment.

    Occasionally, I get an error trying to create one of the SLAIs, and this is what the error message and stack trace look like this.

    *   *   *   *   *

    SLA Error - Not Active: The NameOfSLA ID provided does not correspond with an active SLA.; Organization.ServiceSettings.SLAInstances[0].NameOfSLA

    While performing create on Organization

    Server stack trace: 
       at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs)
       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at ContractLoader5.RightNowService.RightNowSyncPort.Create(CreateRequest request)
       at ContractLoader5.RightNowService.RightNowSyncPortClient.ContractLoader5.RightNowService.RightNowSyncPort.Create(CreateRequest request) in c:\Users\khelfric\Documents\Visual Studio 2013\Projects\ContractLoader5\ContractLoader5\Service References\RightNowService\Reference.cs:line 23139
       at ContractLoader5.RightNowService.RightNowSyncPortClient.Create(ClientInfoHeader ClientInfoHeader, RNObject[] RNObjects, CreateProcessingOptions ProcessingOptions) in c:\Users\khelfric\Documents\Visual Studio 2013\Projects\ContractLoader5\ContractLoader5\Service References\RightNowService\Reference.cs:line 23147
       at ContractLoader5.RNTContract.CreateNew() in c:\Users\khelfric\Documents\Visual Studio 2013\Projects\ContractLoader5\ContractLoader5\RNTContract.cs:line 722

    *   *   *   *   *

    The first exasperating thing is that the SLAs in question ARE ACTIVE!  I export the list from the database in RightNow and import it into a SQL Server db that keeps all the data I have to load.

    The second exasperating thing is that while this error talks about what would appear to be the FIRST element in the list of new SLAInstances at index 0, "Organization.ServiceSettings.SLAInstances[0].NameOfSLA", the number isn't always 0, and it's frequently larger than the number of new SLAInstances , so for instance, one time I was adding 4 SLAInstances , and the message included  "Organization.ServiceSettings.SLAInstances[13].NameOfSLA".  

    I had been specifying the SLA types by name, so I switched from looking up using the actual SLA name to using the ID number, and that didn't help.  In fact, that's a THIRD exasperating thing I discovered.  When you create an SLAInstance, and you want to use the ID to specify the type of SLAInstance to create, you don't use the sla_id (database name), you actually use the sla_set (database name) for the ID.  Talk about confusing...

    Anyway, HELP!  Has anyone seen this error when the SLA type actually exists?  I have to think it's a database issue, but I can't seem to fix it.

     

  • Mike Devenney
    "Too many objects requested" fault returned for...Answered8
    Topic posted April 26, 2012 by Mike DevenneyRed Ribbon: 250+ Points 
    Title:
    "Too many objects requested" fault returned for simple object query
    Content:

    Hi all, 

    I'm having trouble getting into querying objects.  I started with a slightly modified version of the WebServicesSamples code for the BasicQueryObjects.  Working in Visual Studio 2010 (code included below).

    I changed the Namespace and TypeName to match my needs and updated the ROQL select statement to this:  "SELECT Description, PFDid, Qty FROM CO.OrderDetails;"  Can anyone tell me why this would return a fault of "Too many objects requested?"

    edit:  I updated my select statement to read: 
    String queryString = "SELECT CO.OrderDetails FROM CO.OrderDetails WHERE CO.OrderDetails.RNOrderID = 487310;";

    This changes my error message to: Non-existant column: 'RNOrderID'

    Thanks, 
    Mike D

    Version:
    November 2011
    Code Snippet:
  • Jared
    'Requested agent is absent' when agent is availableAnswered4
    Topic posted June 28, 2013 by Jared Gold Medal: 3,500+ Points 
    Title:
    'Requested agent is absent' when agent is available
    Content:

    When using the ChatRouted method on the 3PQ API, sometimes we receive back a failure, with the message 'The requested agent is absent.' The agent is clearly logged in to the chat channel, having in some cases already successfully received a chat interaction. The ChatId and AgentId are correct. Please identify what we can do to further investigate this.

  • Shakil Ahmed
    'SampleClient.RightNowService' already contains a...2
    Topic posted August 29, 2014 by Shakil Ahmed 
    Title:
    'SampleClient.RightNowService' already contains a definition for 'ExceptionCode' getting error C#
    Content:

    When I have added my wsdl as a service using the following instruction.I am getting this compilation error in .net.

    http://documentation.custhelp.com/euf/assets/devdocs/august2014/Connect_Web_Services_for_SOAP/Default.htm

    Error:

    Error    1    The namespace 'SampleClient.RightNowService' already contains a definition for 'ExceptionCode'    D:\VBCode\SampleClient\SampleClient\Service References\RightNowService\Reference.cs    18602    17    SampleClient

    Any suggestion please???

     

Filter by Date

< < December 2019 > >
S M T W T F S
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        

Filter by Type