System Admin and Configuration

Get Involved. Join the Conversation.

Posts

  • Lavish Kumar
    Business rule not sending out emailAnswered18
    Topic posted May 20, 2015 by Lavish KumarGold Medal: 3,500+ Points 
    Title:
    Business rule not sending out email
    Content:

    I am working on the RightNow TEST console. I have a business rule that is set to send an email to custom when incident status is changed to solved.

    I do see the business rule triggering in the "Rule log" but still not receiving any email. Please see screenshot attached 


    Is there any service or something needs to be activated / enabled in order for business rule to send out mail?

    (FYI...I do have the mailbox enabled). When I sent out the mail as proof, then I receive it.
     

    Version:
    Feb 2014 - 3.2 framework
    Image:
  • Scott Heidenreich
    Trigger Task Status change upon Incident SubmitAnswered17
    Topic posted June 12, 2019 by Scott HeidenreichBronze Trophy: 5,000+ Points 
    Title:
    Trigger Task Status change upon Incident Submit
    Summary:
    How do I change the status of a task, once an incident is submitted?
    Content:

    Hello,

    I have created a relationship between the task table (parent) and incident table (child)  This allows OPA to assign an existing task as a parent to the incident.  This is necessary because OPA won't map out to the task table and the incident table at the same time.

    The task is created by a customer contact, and I use the task ID as the object ID in the Contact Checkpoint table.  When the contact creates the task, it is set to "in progress" because it denotes an OPA interview that has been started but not submitted yet.  After the interview is submitted and creates the incident with the Task ID populated, thereby linking the incident to the task, I need to set the status of the task to "Completed", however, I don't see a way to trigger the business rules to do this.

    How do I get OSvC to set a task to "Completed" when the incident is submitted?

    Thank you,

    Scott

    Version:
    18D
  • Duncan Taylor
    Set subject with business rules15
    Topic posted February 22, 2017 by Duncan TaylorSilver Medal: 2,000+ Points 
    Title:
    Set subject with business rules
    Content:

    I'm doing some incident routing based on specific phrases in the email subject line. I can do this no problems, but I would like to be able to delete the keywords I'm parsing from the subject line so they don't clutter the subject name in the CP however, I do not have the option to set the subject line with business rules. Is this a bug or is there a reason I can't set the subject line through rules?

    Version:
    August 2016
  • kate James
    Standard textsAnswered13
    Topic posted June 6, 2019 by kate JamesRed Ribbon: 250+ Points 
    Title:
    Standard texts
    Summary:
    Standard texts and Conditional Statements
    Content:

    Hi, 

    I have a new requirement to display the customer's preferred name if it is not empty, but if Null the first name should be displayed

    I am wondering if there is a way to check the preferred name in standard text?

    Currently we use a variable to get user name from the object

    Hi $contacts.name.first,

    What I want

    Hi if($contacts.c$preferredname is NULL)

    I think it might not be doable in Standard text but templates

    Kind regards,

    Kathy

    Version:
    19A
  • Frank Littlejohn
    Leave Email Subject BlankAnswered124.0
    Topic posted June 19, 2019 by Frank LittlejohnSilver Medal: 2,000+ Points 
    Title:
    Leave Email Subject Blank
    Summary:
    Is there a setting to leave the email subject blank?
    Content:

    When we receive email without a subject, the subject is populated with the first few words of the body of the email. Is there a way to configure it to be left blank or set a default value?

    Version:
    17D
  • Kyle Snay
    Quirky Message Bases in Feb 0912
    Topic posted May 7, 2009 by Kyle SnayGold Crown: 30,000+ Points 
    Title:
    Quirky Message Bases in Feb 09
    Content:

    Recently completed our first upgrade to Feb 09 (from Nov 07) and noticing some weird message base behavior appearing. Hoping someone has a solution to this. Haven't had any luck finding this in the release notes (but let me know if I've missed it):

     

    1. For some reason there's now a new message base 'ANSWERS_AVAILABLE_LBL' that displays a header row on the Answers page:

      answers-available.gif

      Not difficult to remove, simply clear out the content in the message base. But when you do this then a new message base called  ANS_GRPS_LBL appears.

      answer-groups.gif

      It still displays the number of answers but then in parentheses it repeats this information. No idea what an "answer group" is compared to an answer (and how or why the customer is supposed to know this) but even if you edit the message base to get rid of "Groups" I can't find a way to get rid of the redundant parenthetical information. All I want this to do is display the number of answers available like it used to in a pre-Feb 09 classic page set.
       
       
    2. For some reason I can't understand why someone decided to have the HOW_WELL_DID_THIS_ANS_DO_LBL message base on answer feedback to be repeated on the answer page. Here's how it looks on a Nov 07 site:

      helpful2.gif

      On a Feb 09 site it shows up as:

      helpful1.gif

      If you clear the contents of the message base then all you're left with on the answer page are the ratings. Seriously, what's the rationale for the redundancy? confused.gif

    Any help on this would be great. Still begs the question though on the thought processes for why these changes were made to the message base behavior.

     

    Thanks,

    Image:
  • Amanda Jo
    Character limit in message bases.Answered12
    Topic posted September 22, 2009 by Amanda JoSilver Medal: 2,000+ Points 
    Title:
    Character limit in message bases.
    Content:

    Hello there, I'm attempting to edit a message base, but I'm over my character limit (150) for that message base (by alot) but need to include the additional characters.  Is there a way around this or a way to edit the size limit for message bases?

     

    Please help! 

  • Tuğçen İlke Çolak
    out off office agents incidents11
    Topic posted June 5, 2019 by Tuğçen İlke ÇolakRed Ribbon: 250+ Points 
    Title:
    out off office agents incidents
    Content:

    Hello,

    I need to find a way to solve the issue below:

    We are using queue feature of rightnow for the incidents. Our all queues are Round Robin Login. It works well.

    But when the agents log out from the system while they have unresolved incidents, to be able to catch the SLA, the client wants to assign these incidents to the queue again. And then the queue will assign the incidents to the login agents. So my purpose is to check the agents who is not online to the system in last one hour and assign their incidents to the related queue again. Do you have any idea to handle this need?

  • Pavol Procka
    Thread Entry limitations?Answered115.0
    Topic posted December 5, 2018 by Pavol ProckaSilver Crown: 22,500+ Points 
    Title:
    Thread Entry limitations?
    Summary:
    Is there a limit to how many characters/words/lines a thread entry can have?
    Content:

    We noticed that when we send a long email it does not seem to be sent completely.

    While testing, I am getting a bit confusing results. When I just sent random text with all kinds of formatting from OSvC, I received the first 80 lines of the email in my gmail address. When I sent another email with multiple formats but with just the line numbers in it, the received email was cut off at line 94. I then sent an email with just the line numbers again, but this time with simplest possible formatting (no line breaks etc) and received an email ending at line 116 (where even the number 116 was cut off at 1).

    Does anyone know what is happening here? It clearly is not a word or character limit nor a message size limit in MBs (I am not sending any attachments, just plain text). I could not find any config setting for thread entry...

    From what I could find, it should also not be hitting any gmail limits...

    Many thanks

    Pavol

    Version:
    18A
  • chidambaram CT
    Business rule not firing for few contacts11
    Topic posted March 23, 2018 by chidambaram CTBronze Trophy: 5,000+ Points 
    Title:
    Business rule not firing for few contacts
    Content:

    Few hundred contacts are created through customer portal every day. I have written business rule to turn on the flag, when contact is created through customer portal.(Ref attachment)

    When I check rule log, business rule did not fire for 1 or 2 contacts.  I am sure all these contacts are created through customer portal.

    What could be the reason?

Filter by Date

< < September 2019 > >
S M T W T F S
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30          

Filter by Type