Customer Portal

Get Involved. Join the Conversation.

Posts

  • Scott Heidenreich
    Allow Customer to delete a task85.0
    Topic posted June 11, 2019 by Scott HeidenreichBronze Trophy: 5,000+ Points 
    Title:
    Allow Customer to delete a task
    Summary:
    Surface delete capability to customer using a report in CP
    Content:

    Hello,

    I have a report that shows a logged in contact a list of tasks assigned to the contact.  This report is surfaced in the customer portal.  I want to give the contact the ability to delete tasks they are no longer interested in doing.  When I add a delete link to the report in OSvC, it doesn't surface on the customer portal through the Grid widget.

    How do I allow a logged in contact to delete a task from the list? or even mark it for deletion, so I can filter it out of the report?

    Thanks,

    Scott

    Version:
    18D
  • Aparajit Malli
    How to require 1 number in Contact Passwords?3
    Topic posted June 11, 2019 by Aparajit MalliBlue Ribbon: 750+ Points 
    Title:
    How to require 1 number in Contact Passwords?
    Summary:
    How to require 1 number in Contact Passwords?
    Content:

    Hi,

        We have a Password requirement to have at least 1 number in the Contact password. So, in the "Contact Password Configuration", I set the "Numbers and Special Characters" to 1. 

    When I tested it, I gave some alphabets and 1 special character (and no numbers), it still accepted it. 

    Is there a way I can configure to enforce number only (1 number is required per password rules)?

    Any help is appreciated. 

     

    Thanks,

    Aparajit

    Version:
    19A
  • Janusz Jasinski
    How to embed widgets from when the code is saved in the...5.0
    Topic posted June 11, 2019 by Janusz JasinskiBronze Crown: 15,000+ Points 
    Title:
    How to embed widgets from when the code is saved in the system?
    Summary:
    How can I include a widget in a page and make it run when retrieving data from the database
    Content:

    Hi,

    I have created a custom object. Within this custom object is a field of type text, specifically textarea.

    In this field I have put lots of HTML. Exposing this via a custom widget is fine and works. However if I add another custom widget e.g.   <rn:widget path="custom/custom/wmp2020_feedback"/> then it doesn't show, somewhat expectedly (it shows in the source of the page)

    My question is whether it's possible to include a widget like this?

    Thanks,

    JJ

    Version:
    19A
    Code Snippet:
  • Matthew Clarke
    Turn off chat for all interfaces15.0
    Topic posted June 10, 2019 by Matthew Clarke 
    Title:
    Turn off chat for all interfaces
    Summary:
    Enable chat to be closed in all interfaces
    Content:

    Has anyone  set up/configured a master "off" switch for chat, 

    Example scenario, fire alarm is activated and the building has to be evacuated.  Admin would have the ability to action that all ongoing chats are disconnected with a standard message given to the end user. 

    Anyone currently waiting in the chat queue is given a message to say chat is closed for xx reason and chat sign up is disabled with a message displayed that chat is currently unavailable? 

  • Raghavendra Karanth
    Unable to update Incident custom object after upgrade to 3.75.0
    Topic posted June 6, 2019 by Raghavendra Karanth 
    Title:
    Unable to update Incident custom object after upgrade to 3.7
    Summary:
    Unable to update Incident custom object after upgrade to 3.7
    Content:

    We have a menu type custom object inside form of ask.php. <rn:widget path="input/SelectionInput" name="Incident.CustomFields.<package>.<objectName>" />. When we submit this form using the standard method "input/FormSubmit", we receive an error

    " Uncaught exception 'RightNow\Connect\v1_2\ConnectAPIError' with message 'Invalid key: Invalid key 'Incident.CustomFields.<package>.<objectName>' found in list of key value item list' in scripts/cp/core/framework/3.7.3/Models/Incident.php:315"

    1. I have verified that the name of custom object is correct by checking under Framework --> Business Objects -> Incident. I was able to save the form with same code in ver: 3.2

    2. If I create a custom field and try to save the form using "Incident.CustomFields.c.<customFieldName>" the form saves without any error.

    Can someone please guide me as to what could have changed between framework versions and what I would be required to save this custom business object.

     

    Version:
    3.7.3
  • Sergio Andres Barreto Valderrama
    How to add a text in customer portal in a of Navigation Tab...Answered18
    Topic posted June 4, 2019 by Sergio Andres Barreto ValderramaBronze Medal: 1,250+ Points 
    Title:
    How to add a text in customer portal in a of Navigation Tab ?
    Summary:
    Add text in customer portal
    Content:

    How can I change the text found at the end of the "contact us" page for new text?

    I attach the image.


    I appreciate any help!

    Version:
    19A
    Image:
  • Sergio Andres Barreto Valderrama
    How to register a mandatory field by selecting a product...2
    Topic posted June 4, 2019 by Sergio Andres Barreto ValderramaBronze Medal: 1,250+ Points 
    Title:
    How to register a mandatory field by selecting a product type?
    Summary:
    Mandatory Field Selecting a Product type
    Content:

    Hello team!,

    I need to know how I can achieve that if the client selects a category of a specific product, immediately the field of "attachments" is enabled as mandatory.

    I need this only for five categories, that is, when the client selects one of them, the attachment field becomes mandatory. If, on the other hand, the customer chooses another category, leave the normal "attachment" field.

    I have made the attached field mandatory for all categories, but I need it only for specific categories.

    If anyone knows how to achieve it, I appreciate it!

     

    Version:
    19A
    Image:
    Document:
  • Narendra Muttineni
    Create contact if no contact found during SSO Log-In on...Answered2
    Topic posted June 3, 2019 by Narendra MuttineniSilver Crown: 22,500+ Points 
    Title:
    Create contact if no contact found during SSO Log-In on customer portal
    Summary:
    Create contact if no contact found during SSO Log-In on customer portal
    Content:

    Hi All,

    Based on the post https://cloudcustomerconnect.oracle.com/posts/8553262af0, I have created script using pre_login hook to create contact if not found. but this hook only being called if the contact already exist inside the OSvC. Am I missing anything here? I get the following error if contact does not exist in the service cloud ...../error/error_id/saml18/subject/contact.emails.address.

    SSO is working fine if there is contact exist in service cloud but the contact should have the Login otherwise it is getting failed. Is contact.Login is mandatory in order to SSO work successfully.

    Could some one please suggest the right path to implement this?

    Thanks,

    Narendra

    Version:
    18D

Filter by Date

< < June 2019 > >
S M T W T F S
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30            

Filter by Type