Customer Portal

Get Involved. Join the Conversation.

Topic

    DavidTse
    Can't display Integer custom fieldsAnswered
    Topic posted February 6, 2009 by DavidTse Green Ribbon: 100+ Points, last edited October 29, 2011 
    1140 Views, 4 Comments
    Title:
    Can't display Integer custom fields
    Content:

    Created a custom field of type integer for Contacts but can't seem to display it with standard/field/Display widget.  The field's visibility has been enabled for all Interfaces.

     

    Other custom fields of type Menu, Text_Field etc... seem fine.

    Best Comment

    DavidTse

    Ah ok, I think I know why it's not showing now.  The default value is 0 and when the field is set to 0 it doesn't show.

     

    That's ok for us, so I guess case closed :)

     

    Thanks!

     

    David

    Comment

     

    • chris fellows

      Hello,

       

      I created a integer contact custom field and placed it on the account/profile page using the standard/field/Display widget, and it showed up fine.   I was also able to place it on a custom page.  Is there a particular page or template you're trying to put this on?   The example below worked for me.

       

       

      <rn:widget path="standard/field/Display" label="Level" table="contacts" cf_id="1" />

       

       

       

    • DavidTse

      My code looks about the same:

       

      <rn:widget path="standard/field/Display" table="contacts" cf_id="128"/>  

       

      I'm trying to put this on the profile page.

       

      The custom field is of type Integer.

    • monique perkins
      Strange - it should work. Do you have a default value set in the custom field, or are you only pulling a value stored in the db? What are all the visibility bits set to?
    • DavidTse

      Ah ok, I think I know why it's not showing now.  The default value is 0 and when the field is set to 0 it doesn't show.

       

      That's ok for us, so I guess case closed :)

       

      Thanks!

       

      David