Ravello Service

Get Involved. Join the Conversation.

Topic

    Luc Dekens
    Boot DISK can not be empty.Answered
    Topic posted May 27, 2018 by Luc DekensBlue Ribbon: 750+ Points, last edited May 29, 2018 
    326 Views, 10 Comments
    Title:
    Boot DISK can not be empty.
    Summary:
    Boot DISK can not be empty.
    Content:

    Since yesterday evening I keep getting the error "Failed publishing <applicationame>. Boot DISK can not be empty." when I try to Publish a new application.
    In the application there is only 1 VM, which I started from the "Empty Esx" VM template.

    This worked a day ago, but now I can't seem to get around this error.

    Any clue how to analyse and/or fix?

    Best Comment

    Simon Law

    The problem was caused by a recent Ravello update, it has been corrected now.

    -Simon

    Comment

     

    • Simon Law

      Hi Luc,

      Please can you let us know the Application ID of your app that's having this issue? If you go to the Application Canvas and you should see the ID listed as a number in the URL. Something like this

      https://cloud.ravellosystems.com/#/0/apps/XXXXXXXXXXXX/canvas

      I can get support to take a look.

      -Simon

    • Luc Dekens

      Hi Simon,
      I just created a new application, and I get the same message when I Publish.
      The application ID is 3125667234160.
      Luc

    • Luc Dekens

      Just noticed, when I click the Information button for the Empty ESX image in the VM Library,

      emptyesx-i.png

      I get a 404.

      emptyesx.png

      For all other images I get an informational page.

    • Luc Dekens

      It seems there are other images whose Information page ends in a 404.
      So most probably unrelated to the issue I'm experiencing.

    • Luc Dekens

      "A funny thing happened on the way to the forum...".

      I did try the Publish again a minute ago (on the application I passed along earlier), and now it works without the message.

      Did something change in the mean time?
      Or am I loosing my ...?

    • Simon Law

      Hi Luc,

      Not, it wasn't you, it was us :-) I asked support to look into your application and they confirmed it was fixed this morning. Let me know if you are still seeing problems.

      -Simon

    • Luc Dekens

      Thanks, I can confirm the issue is gone.

      Was this a known issue? Can it reoccur in any new application I create?

    • Simon Law

      The problem was caused by a recent Ravello update, it has been corrected now.

      -Simon

    • Luc Dekens

      I'm afraid the issue is back (application 3125667234160)

      bootdisk.png

    • Luc Dekens

      Well it's sort of back...

      I created a 2nd VM in the application, and I indeed didn't define a boot DVD.
      Once I add an ISO to the CD drive, I can Publish the application.

      Does this mean that connecting a disk image is required for a new VM (where the harddisk is empty)?