Policy Automation for B2C Service

Get Involved. Join the Conversation.

Topic

    Muthulakshmi Muthaiah
    How do I create an incident In OPA
    Topic posted January 5, 2017 by Muthulakshmi MuthaiahBronze Trophy: 5,000+ Points, last edited January 11, 2017 
    324 Views, 9 Comments
    Title:
    How do I create an incident In OPA
    Content:

    Hi All,

    How to create an incident through oracle policy automation.

    We can create a contact from OPA but we are facing issues while creating the incident.

    KIndly give me idea on this.

    Thanks,

    Muthu

    Subject edited by Danette Beal for clarity

    Comment

     

    • Anuj Behl

      Hi Muthu,

      It should work the same way put incident fields and map it to Service Cloud.

      What issues are you facing while creating the incident? What type of interview are you working on? This Service Cloud section in OPA documentation gives a basic idea of how to integrate the two.

      -Anuj

    • Joe Aravind

      Hi Anju,

      I am getting Error message while creating incident through customer portal But incident got created in service cloud.

      Error Message : An error has occurred while loading or saving data.
      For further assistance please contact support.

       

      Thanks,

      Joe

    • Fiona Guy

      Hi Muthu

      Without seeing your policy model it's hard to diagnose. Perhaps start by reviewing the list of mapping limitations, particularly checking that every attribute belonging to the incident is correctly mapped. 

      Fiona

       

    • Fiona Guy

      Also the Student Benefits example project installed with Policy Modeling (Policy Modeling Project tab -> Open Example Project) shows an example of creating an incident - perhaps check that works in your environment and compare what is different in your own policy model.  

    • Blessing Matore

      Go to your hub, open message logs and look at the error details. 

    • qi yipeng

      Hi, 

      I used the system project studentbenefits, and this problem has also appeared. Can you tell me how to solve this problem?

      Please give me some advice.

      Thnak you,

    • Jasmine Lee

      I think that StudentBenefits demo example should just work if everything is set up correctly.

      Have you confirmed that your OPA Hub and your Service Cloud site are connected? You can check this by going to the Connections section of your Hub and seeing if your Service Cloud site is listed there, and whether the status is a green tick.

    • Jasmine Lee

      If the OPA Hub and the Service Cloud site are connected, then in OPM you'd also need to edit the connection so that it's pointing to your Hub with your Service Cloud connection. This is done in Oracle Policy Modeling (OPM): 

      • Go to the OPM Data tab > Mapping Settings
      • At the bottom of the Mapping Settings window, there's an option to change the Connection. Click 'change' and it will ask you to log into your Hub, then you'll get a list of available connections from your Hub.
      • Select the Service Cloud connection.
    • qi yipeng

      Hi, Jasmine Lee

      I have already done what you said. I have already connected the OPA to the service cloud and the connection shows a green icon. Also in this project, I changed the connection in the Mapping Settings and pointed it to my hub. This problem has caused me problems, I don't know how to solve it, so I can't do the next step.