Integration

Get Involved. Join the Conversation.

Topic

    Arvind Mathivanan
    Connectivity issue between SOACS and Pluggable Database
    Topic posted October 21, 2019 by Arvind MathivananBronze Medal: 1,250+ Points, tagged Cloud, Connection, Database, Integration, PaaS, SOACS 
    24 Views, 2 Comments
    Title:
    Connectivity issue between SOACS and Pluggable Database
    Summary:
    We receive Resource Dead Exception for the Datasource that we use to connect PDB from SOACS
    Content:

    Hi Team,

    We are connecting to Pluggable Database from SOACS. Recently the PDB was upgraded to the latest version. From then, we see resource dead exceptions on the connectivity from SOACS. Support team tried reseting the connections, restarted the datasource, restarted the admin,managed servers.  The ACLs were also checked and made sure to be opened between SOA and PDB. I am able to connect to PDB seamless from outside SOACS.

    1. What could be the issue in this case in SOACS? 

    2. What are the admin related activities that you expect to be checked/done in SOACS whenever a pluggable database is upgraded?

    Error Received in SOA :

    Exception occurred when binding was invoked.
    Exception occurred during invocation of JCA binding: "JCA Binding execute of Reference operation 'insert' failed due to: Could not create/access the TopLink Session.
    This session is used to connect to the datastore.
    Caused by weblogic.jdbc.extensions.ConnectionDeadSQLException: weblogic.common.resourcepool.ResourceDeadException: 0:weblogic.common.ResourceException: Could not create pool connection for datasource 'ErpSaaSExtnNonXA'. The DBMS driver exception was: IO Error: The Network Adapter could not establish the connection.
    You may need to configure the connection settings in the deployment descriptor (i.e. DbAdapter.rar#META-INF/weblogic-ra.xml) and restart the server.  This exception is considered retriable, likely due to a communication failure.
    

    Comment

     

    • Kanchankumar Khedkar
      could not create pool connection for datasource 'ErpSaaSExtnNonXA'. The DBMS driver exception was: IO Error: The Network Adapter could not establish the connection.
      You may need to configure the connection settings in the deployment descriptor (i.e. DbAdapter.rar#META-INF/weblogic-ra.xml) and restart the server.
      

      This error is communication error between WebLogic and DB Instance. I would check below :

      We may get clue from diagnostic logs. Please check those. 

      1. Connectivity with port between using telnet from all machines where weblogic is installed. 

      2. Check if you are able to create a new datasource and test it successfully or not. Please check connection url whether it uses ":" or "/" (service name vs id) and correct if necessary . And then correct it across database connections. 

      3. Please check if Plan.xml is copied on every node in clustered. 

      Once all above things are done. Please restart all nodes and test connectivity. Hope one of the above step helps in resolving issue. 

       

      Thank you. 

       

      • Pradosh Prusty

        Hi ,

        Can you please send the screenshot of the Datasource connection. There was an issue while giving the Datasource connection in the Weblogic Console. It doesn't generate teh right JDBC URL after entering and saving it .

        We had the similar issue and we had corrected it manually.

        Thanks

        Pradosh