Planning

Get Involved. Join the Conversation.

Topic

    Amit Agarwal
    Error in PBCS Forms - Connection Error
    Topic posted September 19, 2019 by Amit AgarwalBlue Ribbon: 750+ Points, tagged EPBCS, EPM Automate, Financial Planning, Forms, Free Form Planning, Integration, PBCS, Projects, Setup, SmartView 
    52 Views, 6 Comments
    Title:
    Error in PBCS Forms - Connection Error
    Summary:
    Error 504 - A connection to the server has failed (Status = 504)
    Content:

    Hi All,

    Greetings!!

    We have recently implemented PBCS and soon to go live. We are getting a error in PBCS Forms - "A Connection to the Server has Failed. (status=504).

    I fail to understand what is causing this error. Seeking help from all the champions here.

    Thanks in advance.

     

    Amit

    Image:

    Comment

     

    • Peter Nitschke

      Is this happening every time? Or just intermittently? And is it specific forms or all forms? 

      I can't say I've ever seen that before! 

      P

    • Amit Agarwal

      Hi Peter-

      This is happening when we are using a huge data form with numerous rows and columns. And its happening with all the users, not specific to a few. 

      Please advice from your experience.

      Many Thanks,

      Amit

       

      • Peter Nitschke

        The obvious might be to shrink the form a little - but honestly I'm surprised you'd not hitting the form size limit before this error. 

        Any chance there are a lot of dynamic calcs on the form? And is it BSO or ASO? And does it happen if you open the form in Smartview? Or just the web layer? 

        It almost looks like something is timing out in the middle. Be fascinating to see what the essbase log says. 

        You're definitely going to need to raise an SR to get the tech guys to look at it. 

        p

    • Amit Agarwal

      Hi Peter -

      There are no dynamic calcs, Its ASO. Its happening in Web layer and we haven't tested it on Smart view.

      Let me know your thoughts.

       

      Thanks,

      Amit

    • Peter Nitschke

      It's certainly possible to build an ASO dataform that is too big even suppressed and will time out. That said, surprising to see one that doesn't have member formulas on it - normally ASO will render even a few thousand lines reasonably well if it's just raw data. How big is it exactly? 

      I'd recommend running a manual slice merge over it and see if the form comes back. 

      Can I just confirm - did it 'ever' work? Like did it work during dev but once it's fully loaded up with data it doesn't work? 

      Cheers

      Pete

       

       

    • Amit Agarwal

      Thanks Peter. Let me come back to you with some more info on this.

      Amit