Reporting and Analytics for Service

Get Involved. Join the Conversation.

Topic

    kerry walker
    Using Score as a variableAnswered
    Topic posted January 3, 2019 by kerry walkerGold Medal: 3,500+ Points 
    42 Views, 5 Comments
    Title:
    Using Score as a variable
    Summary:
    Using Score as a variable
    Content:

    Good day, and Happy New Year!

    We’ve recently run into an issue with a survey report we’ve had running for a few years.  Its set up so that a separate summary report is created for each of the responses to the first question.  The first question asks which phone number a user called.  The goal was to be able to send survey data to different sections of a call center, based on the phone number a user called, and it would only contain responses for users who’ve chosen that phone number.  

    Originally, this was all accomplished using the variable “score” which we believe is “answers_sessions.score.”  Recently, we’ve encountered an error that basically tells us that score is no longer valid and cannot be used.  I can only assume something has changed between versions of the client.  We tried creating a custom score field under contacts, but that has not worked.  I’m wondering if anyone has an idea how we can continue this approach another way, without using the score?

     

    Thank you in advance!  =D

    Version:
    18B

    Best Comment

    kerry walker

    I wanted to follow up with some additional information about the “score” field being invalid. We’ve been working with OSvC Support and they’ve been very helpful in identifying an issue that their development team is working on fixing for future versions.

    Restating part of our issue, we were not able to update our survey and save it without manually adding the score field and value back in. If another update needed to be made to the survey, the prior changes would not appear (which is one reason we were trying to find a solution on the forum). OSvC Support has let us know that the workaround is - to update the score field and value every time the survey needs to be modified. Although tedious, it seems like this will work for us until the issue is fixed within the client.

    Right now, we’re using version 18B. Hopefully, this will help anyone else who’s having issues with fields and values within their surveys that aren’t saving.

    Thank you to all!

    -Kerry

    Comment

     

    • Sebastiaan Draaisma

      Hi Kerry.

      Best wishes to you to :-)

      So, you have 1 survey and based on the answer in the first question you would like to send different reports to different call centers right?

      Depending on the question type (matrix, free text etc) you would need to create a report for each call cener where you have this first question in a runtime filter (locked to the phone number for that call center report) and include only the results when these match. Another aproach would be to use a custom script where you perform a regular expression search and only include results where the number matches in Q1. This would also require 1 report per call center as you want to have them scheduled. You might be able to do it all in one report when using a custom script aproach in combination with an alert but it depends on other information in your report (headers, footers, pictures, colors etc)

      Hope this gives you an idea?
      Let me know if you need aditional help :-)

    • kerry walker

      Hey Sebastiaan, 

      Thanks for the thorough response!  I think its currently set up like your first option, but I'm going to dive in further to see if either of these might work for us.  I will let you know if I have questions (I'm sure I will).  =D

       

      -Kerry

    • kerry walker

      I wanted to follow up with some additional information about the “score” field being invalid. We’ve been working with OSvC Support and they’ve been very helpful in identifying an issue that their development team is working on fixing for future versions.

      Restating part of our issue, we were not able to update our survey and save it without manually adding the score field and value back in. If another update needed to be made to the survey, the prior changes would not appear (which is one reason we were trying to find a solution on the forum). OSvC Support has let us know that the workaround is - to update the score field and value every time the survey needs to be modified. Although tedious, it seems like this will work for us until the issue is fixed within the client.

      Right now, we’re using version 18B. Hopefully, this will help anyone else who’s having issues with fields and values within their surveys that aren’t saving.

      Thank you to all!

      -Kerry

    • kerry walker

      I agree!

      Once we verify that is has been resolved completely, I can update this post again. 

      Thank you for all of your support!

       

      -Kerry