Policy Automation for B2C Service

Get Involved. Join the Conversation.

Topic

    Scott Heidenreich
    OPA Mobile App function
    Topic posted November 12, 2019 by Scott HeidenreichBronze Trophy: 5,000+ Points 
    29 Views, 3 Comments
    Title:
    OPA Mobile App function
    Summary:
    Submit function isn't advancing to last screen
    Content:

    Hello,

    The OPA Mobile app doesn't seem to advance to the last screen in the interview (the one marked as always being shown) after the submit button is pressed, nor after syncing a completed interview and returning to look at it.

    Also, It seems like the model isn't reacting to information retrieved after submit, until a button is clicked.

    Is this a bug?

    Version:
    19B

    Comment

     

    • Chris Flemming

      Hi Scott,

      In the mobile application when you press the submit button you should see a prompt asking whether you want to mark the interview for upload. If you select "yes" you will be returned to the assessments list page. If you select "no" you will not advance in the interview - the assessment must be manually marked for upload on the assessments list page. After syncing the completed interview you should be able to view the final screen if you return to the assessment.

      Regarding the model not reacting to information retrieved after submit until you press a button - what information is being retrieved and what are you expecting to happen?

      Thanks,
      Chris

    • Scott Heidenreich

      Thank you for your reply, Chris.  The circumstance is selecting "Yes" after a submit button is clicked.  Then syncing, then returning to the interview on the device.  During sync, the incident last updated date/time is being retrieved mapped in from the incident after submit.  I'm using this to determine if the user has synced the model, and if so, trying to hide the screen with the submit button.  This is necesary, because if the user opens the interview and clicks the submit button again, it puts the model into the upload queue again, even though it was already synced and the mobile assessment marked as completed in OSvC.  Then the next time the user syncs, an error is thrown, resulting in the cryptic error occurred contact hub administrator.  But there isn't anything that an administrator can do, other than set the mobile assessment that was completed, to cancelled. This seems like a bug, as the user shouldn't be able to put a model that was already synced back into the upload queue.

      So to prevent this from happening, I'm checking to see if the incident last updated time has been retrieved from the incident, as I only allow the interview to do that after a sync back up to OSvC, and if the attribute has a value, then hiding the screen with the submit button on it, and showing a copy of the screen without the submit button, but with a message that the interview was already synced.

      However, after sync occurs, if the user again opens the interview, the screen with the submit button is still visible on the screen, as it was the last screen the user was on, rather than the screen without the submit button.  If however, the user clicks a back button from the screen with the submit button on it, then clicks next, the screens will switch off and on as intended.

      It would be very nice to be able to show the submit button conditionally.  It also seems that once an interview has been synced back to OSvC, the submit button should have no effect - the interview should remain completed.

      I also don't know how to get completed interviews off of the device. Cancelling them after they have been completed is a non-starter as we need the completed status. and leaving them on the device indefinitely isn't a good idea either, as they take up storage and the list will get crazy long over time.

    • Chris Flemming

      Hi Scott, I think I need to see this in action to properly understand the issue. Are you able to share the details of an OPA Hub site and associated Service Cloud site that I can use to reproduce the problem? Via email is fine.

      Thanks,
      Chris