Field Service

Get Involved. Join the Conversation.

Topic

    saurabh suman
    SOAP Ui to OFSC
    Topic posted September 28, 2016 by saurabh sumanRed Ribbon: 250+ Points 
    498 Views, 14 Comments
    Title:
    SOAP Ui to OFSC
    Content:

    Hi All

    I am trying to create activity by using soap ui. I am getting the following error
             <result_code>17</result_code>
             <error_msg>Can't create activity: 65574: insert_appointment: The 'workTypeId' mandatory property is not assigned.</error_msg>
     Any clue what is this worTypeId.

    Comment

     

    • Hardik Gupta

      Hi Saurabh,

      Under Appointment section you need to add any one of the following:

      <worktype>[string?]</worktype> OR

      <worktype_label>[string?]</worktype_label>

      Regards,

      Hardik Gupta

    • saurabh suman

      i Added <worktypeid> and now i am getting bad request...by any chance do u know what is this worktype id

    • Hardik Gupta

      Hi Saurabh,

      <worktypeid> this tag doesnt exist. That is why you are getting bad request.

      Please use any one of these:

      <worktype>[string?]</worktype> OR

      <worktype_label>[string?]</worktype_label>

      Regards,

      Hardik Gupta

       

    • saurabh suman

      Hi HArdik

       

      I added WorkTypeId,,,but now i am getting Bad Request...any clue as to what is this Work Type ID actually is...

    • Hardik Gupta

      Hi Saurabh,

      Under Activity types there are several activity types that one creates.

      If you check there is an ID column on left. That is the worktypeId. 

      Regards,

      Hardik Gupta

    • saurabh suman

      Hi Hardik

      i tried this way

             <properties>
                      <name>worktype</name>
                      <value>Installation</value>
                   </properties>...but still i got the same worktypid not assigned error

      and then i tried <worktype> Installation</worktype> but same error

       

      by any chance u have any xml that worked for u in soap ui to create activity u can share.

    • Hardik Gupta

      Hi Saurabh,

      If you are using the name of the Activity then use this tag <worktype_label>[string?]</worktype_label>

      Also <worktype_label>[string?]</worktype_label> this is a separate tag under <appointment>

      Your syntax is wrong.

      The right way is:

      Suppose Activity type ID is 12 and Activity Name is Installation and Activity Label is INS then:

      <appointment> 
                                  <worktype>12</worktype>

      <properties>

      ....This is optional

      </properties>

      </appointment>

      OR
      <appointment>     

                            <worktype_label>INS</worktype_label>

      <properties>

      ....This is optional

      </properties>

      </appointment>

      I hope this solves your issue.

      Regards,

      Hardik Gupta

    • saurabh suman

      I am adding my response completely. Still not solved :(  Not sure what issue is ... 

      <worktype>12</worktype>
               <date>2016-09-28</date>
               <resource_id>USEast</resource_id>
               <position_in_route>first</position_in_route>
               <!--Zero or more repetitions:-->
               <properties>
                  <name>appt_number</name>
                  <value>apt1234</value>
               </properties>
               <properties>
                  <name>language</name>
                  <value>en</value>
               </properties>        
               <properties>
                  <name>customer_number</name>
                  <value>SStest</value>
               </properties>
               <properties>
                  <name>name</name>
                  <value>sstest1</value>
               </properties>
               <properties>
                  <name>zip</name>
                  <value>07001</value>
               </properties>
               <properties>
                  <name>aworktype</name>
                  <value>4</value>
               </properties>
                <properties>
                  <name>atype</name>
                  <value>4</value>
               </properties>
              <properties>
                  <name>time_slot</name>
                  <value>07-09</value>
               </properties>
                    <properties>
                  <name>time_zone</name>
                  <value>GMT</value>
               </properties>
               <properties>
                  <name>duration</name>
                  <value>40</value>
               </properties>

    • Hardik Gupta

      Hi Saurabh,

      Now what is the response that you got? I can see the payload is still not correct.

      The <properties> tag is this way

      <properties>

      <property></property>

      <property></property>

      </properties>

      Regards,

      Hardik Gupta

    • Hardik Gupta

      Hi Saurabh,

      For testing I suggest you work with bare minimum tags.

      Get an initial first Response right and then work your way with more complex structures.

      Sample <head> and <data> snippet.

      <head xmlns="">
                     <processing_mode>appointment_only</processing_mode>
          <upload_type>incremental</upload_type>
          <appointment>
          <keys>
          <field>appt_number</field>
          </keys>
         
          </appointment>
          <inventory>
          <keys>
          <field>invsn</field>
          </keys>
          </inventory>
                  </head>
                  <data xmlns="">
                      <!-- Optional -->
                      <commands>
                          <command>
                              <date>2016-09-28</date>
                              
                              <type>update_activity</type>
                              <external_id>61233</external_id> <!-- Replace this-->
                              <appointment>
                                 <appt_number>5809</appt_number> <!-- Replace this-->
       <duration>30</duration>
       <worktype_label>CR</worktype_label> <!-- Replace this-->
       <name>name12</name>
       <phone>11111111</phone>
       <email>email@email.com</email>
       <cell>11111111</cell>
       <address>216-218 Camberwell Rd</address>
       <city>London</city>
       <zip>SE5 0ED</zip>
       <language>en</language>

                                </appointment>
                                  
                          </command>
                      </commands>
                      <!-- Optional -->
                      
                  </data>

       

      Try this out and replace the correct value as in your system for  <!-- Replace this--> markers.

      Regards,

      Hardik Gupta

    • saurabh suman

      Hi Hardik

      The xml structre that is sent you is built when i created the request from wsdl. However i tried to build xml using ur structre but it did not work.

      seems it works like <properties></properties>

      <properties></properties>

      ...

      back to square one..btw it is working for u in soap

    • Hardik Gupta

      Hi Saurabh,

      Let me know what is the error you are receiving.

      I have successfully done this with the above request.

      Please refer the docs http://docs.oracle.com/cloud/latest/fieldservicecs_gs/FAISD/FAISD.pdf

      The <properties> structure is what I said.

      <properties>

      <property></property>

      <property></property>

      </properties>

      It is clearly mentioned in the Inbound SDK doc

      Also the wsdl structure of Inbound complies with my structure that I have shared.

      Regards,

      Hardik Gupta

    • saurabh suman

      Hi Hardik

      Will it be possible for you to share ur wsdl with me or let me know from where can i get the wsdl for inbound sdk..i believe u r ryt i went through your doc link...

      Regards

      saurabh suman

    • Hardik Gupta

      Hi Saurabh,

      Below is the wsdl link

      https://api.etadirect.com/soap/inbound/?wsdl

      Regards,

      Hardik Gupta