Integration

Get Involved. Join the Conversation.

Topic

    Surya Satyanarayana
    OIC connectivity agent JMS issue
    Topic posted October 26, 2018 by Surya Satyanarayana, last edited October 26, 2018, tagged Adapters, Agent, Cloud, Connection, Integration 
    162 Views, 4 Comments
    Title:
    OIC connectivity agent JMS issue
    Summary:
    JMS connectivity issue for manage server port
    Content:

    We are trying to connect to manage server port for weblogic server but are getting the below issue.

    Test connection failed. Please ensure you are providing correct Weblogic JMS Admin host and port. Error Details : While trying to lookup 'weblogic.management.mbeanservers.domainruntime' didn't find subcontext 'management'. Resolved 'weblogic'

    The same connection for admin port is working fine. We tried to place few libraries and restarted the agent but have got a different error now.

    • java.lang.NoClassDefFoundError: Could not initialize class weblogic.security.SubjectUtils

    Any idea what all libraries need to be added for the weblogic JMS connection to work for manage server port.

    Thank you.

    Surya

    Version:
    OIC Version: 18.3.5.0.0

    Comment

     

    • Nagireddy Tadi

      Please configure connection by providing admin server host and port details.

       Not sure why you are trying with managed server details?

      • Surya Satyanarayana

        Thanks for the reply. I would need manage server port as the JMS module for the queues is targeted to manage server. Any idea how I can get around this, please let me know( We will not be targeting the JMS modules and JMS server to admin server).

        Regards

        Surya

    • Nagireddy Tadi

      Though you configure admin server and port in connection you can browse Queues which are targeted to Managed server. No need to configure connection with managed server and port.

    • John Graves

      This is true.  The connector points to the admin server details.

      However, after getting the connector activated, I was unable to attach in the integration to a queue on a managed server:

      https://cloudcustomerconnect.oracle.com/posts/73947e4c18

      If you have success, please let me know.

      -John