Policy Automation for B2C Service

Get Involved. Join the Conversation.

Topic

    Kurt Helfrich
    OPA-E00476 Java 7 or later is required to run the embedded...Answered
    Topic posted July 31, 2017 by Kurt HelfrichGold Trophy: 10,000+ Points 
    352 Views, 18 Comments
    Title:
    OPA-E00476 Java 7 or later is required to run the embedded web server.
    Content:

    I had to update to OPA May 2017 recently, and today, I got a Java update notice.  I was behind, and Java updates are (usually...) harmless, so I updated to Java 8 Update 144.  I can see in Control Panel > Programs and Features that it's installed.  Now I get an error when I try to launch the debugger.

    Oracle Policy Modeling
    The debugger is not available: Java 7 or later is required to run the embedded web server.  Java 0 () was found.  (OPA-E00476)

    Help!

    Version:
    OPA May 2017

    Best Comment

    Kurt Helfrich

    It appears that our company IT has shot me in the foot yet again.  We are rolling out BeyondTrust's PowerBroker (or maybe PowerBorker?!?) software to control our access to our PCs, and I'm in the guinea pig group.  Once I stopped the 2 PowerBroker services (surprised that I could), I was able to debug.  Thanks, IT...

    Comment

    • Kurt Helfrich

      I started a service request, and I did include a link to this.  Great minds thinking alike...

    • Kurt Helfrich

      It appears that our company IT has shot me in the foot yet again.  We are rolling out BeyondTrust's PowerBroker (or maybe PowerBorker?!?) software to control our access to our PCs, and I'm in the guinea pig group.  Once I stopped the 2 PowerBroker services (surprised that I could), I was able to debug.  Thanks, IT...

    • Davin Fifield
      Thanks for sharing the resolution Kurt.