Customer Portal

Get Involved. Join the Conversation.

Topic

    Eric Gottesman
    Embedded Chat Inlay not observing Holiday Hours?Answered
    Topic posted September 4, 2019 by Eric GottesmanBlue Ribbon: 750+ Points, last edited September 4, 2019 
    30 Views, 3 Comments
    Title:
    Embedded Chat Inlay not observing Holiday Hours?
    Content:

    Our client has embedded inlay chat set up on their website. This past Monday was the Labor Day holiday in the US, and OSvC is configured to recognize that holiday. On their website, they don't recognize the holiday configuration, so the button to initiate chat was visible.

    Apparently, customers were able to click on the chat button to request a chat even though no agents were available, and again, it was configured as a holiday in OSvC. Details in attached image. (The "serviced" requests in the picture were actually "End-user Lost", which means they closed the tab or went to another page.)

    So, I guess my question is whether Inlay Chat should be honoring that Holiday configuration? It seems like it should. I know it pays attention to chat hours that we configure.

    Also, shouldn't there be a message if no agents were available, even if the holiday setting is ignored? I would expect the behavior to be something like what happens outside of chat hours.

     

    Version:
    19A
    Image:

    Best Comment

    Eric Gottesman

    MYSTERY SOLVED! It's actually working as expected. I was doing some testing to try and figure out what was happening. I set up a test holiday, and I noticed that the default chat launch page was also not displaying a holiday message. So, I started wondering if it was a configuration item. Did some searching, and sure enough, it is! CS_HOLIDAY_MSG_ENABLED needs to be set to Yes, default is No. Once I set it to Yes, the chat shows the message "It is currently a holiday" - works for anonymous as well as non-anonymous.

    Posting here in case anyone else runs into this issue.

    Comment

     

    • Willie Eide

      It should have returned with the fact that it is a holiday. 
      Currently the embedded chat does not check for off hours or holiday when first loaded. As this required an initial server hit it will need to be a conscious request by the customer. More details to come about that.

      • Eric Gottesman

        Thanks for this info, and I look forward to more details. I couldn't find documentation about this so any leads will be appreciated!

    • Eric Gottesman

      MYSTERY SOLVED! It's actually working as expected. I was doing some testing to try and figure out what was happening. I set up a test holiday, and I noticed that the default chat launch page was also not displaying a holiday message. So, I started wondering if it was a configuration item. Did some searching, and sure enough, it is! CS_HOLIDAY_MSG_ENABLED needs to be set to Yes, default is No. Once I set it to Yes, the chat shows the message "It is currently a holiday" - works for anonymous as well as non-anonymous.

      Posting here in case anyone else runs into this issue.