Policy Automation for B2C Service

Get Involved. Join the Conversation.

Topic

    Tuğçen İlke Çolak
    OPA-Service Cloud Connection Problem
    Topic posted June 23, 2017 by Tuğçen İlke ÇolakRed Ribbon: 250+ Points 
    354 Views, 8 Comments
    Title:
    OPA-Service Cloud Connection Problem
    Content:

    Hi Community,

    I have an issue between OPA and Service Cloud.I checked the message logs:

    OPA-ERR-001

    SOAP Action "http://oracle.com/determinations/opahub/getendpointmetadata" Error parsing request: Endpoint 'RightNow' is invalid.
    

    Also when i clicked the Connections on Hub, i dont see fields which we write  Rightnow's username and password. So i cannot use the rightnow user which i create for OPA. I attached the screenshot.

    Can you please help me?

    Document:

    Comment

     

    • Simon Kilgarriff

      Hi,

      I'm not sure about your error, but with regards to the OPA user I was told that the OPA user is not required since Feb 16 version of OSvC.   The green check/tick seems to suggest the connection to the Service Cloud site is good.

      It might be best to raise a support ticket to get them to find out what the issue with the link between the two sites is.

       

       

       

    • Shreyas Pandhari

      Hi,

      Ideally you should get the Username and Password text boxes in RightNow Connect Web Service Details section of OPA hub. As per the latest documentation (May 2017) available on community it does require username and password for connection. One of the reasons can be if your organization has an SSO enabled in that case it is possible that credential fields are not visible. I hope the issue is already resolved at your end as there is no post past 23rd June 2017. 

      Thanks,

      Shreyas

    • Davin Fifield

      As Simon said, connections to Service Cloud sites that are Feb 16 or later do not require manual configuration of a username/password. The connection is taken care of automatically behind the scenes.  The username/password fields do not appear in that case. 

    • Danette Beal

      Hi  Tuğçen,

      Let us know if Simon and Davin were able to help! I'd love to be able to set a best answer and get you what you need.

      Regards,

      Danette, Community Manager

    • Tuğçen İlke Çolak

      Hi,

      I understood, i dont need to enter user name and password. Now i can see the connection. I can add Opa as a control on workspace. I deployed the project. I tried to create really basic project. But at the end i colud not create incident or contact on agent desktop. What am i doing wrong?

    • Davin Fifield

      Steps to try:

      1. Look at the message log in OPA Hub. What are the messages it is reporting?

      2. Have you tried deploying the included ServiceCloudSimple example project?

       

    • Tuğçen İlke Çolak

      Hi,

      I checked the message log. It does not seem any problem. I want to use OPA on Agent desktop. Because of that I deployed to StudentBenefits project. When i checked the mapping settings on student benefits project, it seems that  will be created incident at the end of the flow. I answer the questions on osc agent desktop. I could not create any incident. Normally example projects work without any implemantation right?  Also Can i use the ServiceCloudSimple project on AgentDesktop, if i checked contact center agent on mapping settings?

    • Davin Fifield

      Yes, both approaches should work.

      What happens when you click the Submit button in the OPA interview? Does it give an error? If you could upload a screenshot of your Mapping Settings and of the workspace where the OPA control is embedded after you hit Submit, we may be able to see something obvious.