Planning

Get Involved. Join the Conversation.

Topic

    Yaniel Delgado
    Copy Rates Across Entities Rule Error
    Topic posted July 19, 2018 by Yaniel DelgadoGreen Ribbon: 100+ Points, tagged Workforce 
    45 Views, 1 Comment
    Title:
    Copy Rates Across Entities Rule Error
    Summary:
    I received an error running the rule.
    Content:

    When I tried to run rule Copy Rates Across Entities I received the error below:

     

    This rule cannot be launched because it has hidden rtp variables without default values.

     

     

     

    What are the rtp variables? How can I unhide the rtp variables? How can I add the default values to the rtp variables?

     

    Thanks in Advance,

    Comment

     

    • Mark Rinaldi

      Could you elaborate a little more on what you were doing?  Had you already run the "One Time - Copy Rates to Months" rule?  Where were you launching it from?

      I have run this rule without issue several times.  I've tried it from the Rule Card (not Calc Manager) as well as from the Actions menu on the Rates form within the Benefits & Taxes Wizard and it always works for me.

      You can look in Calc Manager to see the Variables associated with the rule and set a default (such as Scenario and Version).  There are several "Hidden" RTPs since it should be launched from the Rates form on the B&T Wizard where it will pick up the Scenario, Version, Currency, and Component and only show the prompts for the Source Entity and Target Entity.