System Admin and Configuration

Get Involved. Join the Conversation.

Topic

    Lavish Kumar
    Business rule not sending out emailAnswered
    Topic posted May 20, 2015 by Lavish KumarGold Medal: 3,500+ Points 
    805 Views, 18 Comments
    Title:
    Business rule not sending out email
    Content:

    I am working on the RightNow TEST console. I have a business rule that is set to send an email to custom when incident status is changed to solved.

    I do see the business rule triggering in the "Rule log" but still not receiving any email. Please see screenshot attached 


    Is there any service or something needs to be activated / enabled in order for business rule to send out mail?

    (FYI...I do have the mailbox enabled). When I sent out the mail as proof, then I receive it.
     

    Version:
    Feb 2014 - 3.2 framework
    Image:

    Best Comment

    Anurag Mittal

    Lavish, can you make sure your Transactional mailing is in launched state and second thing can you open report Id 2009 ( Mailing Delivery Queue ) and see if you have any email in Queue.

    Let us know your finding

    Regards,

    Anurag

    Comment

    • Anurag Mittal

      FYI, If a survey is scheduled to be delivered after a certain time period then only it is held in the mail_queue else it will be sent immediately (won't stuck at least in queue). 

    • Lavish Kumar

      Thanks Anurag, you are always very helpful :)

      This is certainly good to know. I am going to try it and see if I receive the survey mail.

    • Lavish Kumar

      Hello Anurag, I  did try setting up time to 0. That was yesterday and still I have not received any email (When I set to 0, the mailing never triggers the business rule that send out the mailing)

      But, when I just changed the rule time back to 1, the incident triggered the rule and the mailing went in the queue.

      See attached screenshot