System Admin and Configuration

Get Involved. Join the Conversation.

Topic

    Lavish Kumar
    Business rule not sending out emailAnswered
    Topic posted May 20, 2015 by Lavish KumarGold Medal: 3,500+ Points 
    805 Views, 18 Comments
    Title:
    Business rule not sending out email
    Content:

    I am working on the RightNow TEST console. I have a business rule that is set to send an email to custom when incident status is changed to solved.

    I do see the business rule triggering in the "Rule log" but still not receiving any email. Please see screenshot attached 


    Is there any service or something needs to be activated / enabled in order for business rule to send out mail?

    (FYI...I do have the mailbox enabled). When I sent out the mail as proof, then I receive it.
     

    Version:
    Feb 2014 - 3.2 framework
    Image:

    Best Comment

    Anurag Mittal

    Lavish, can you make sure your Transactional mailing is in launched state and second thing can you open report Id 2009 ( Mailing Delivery Queue ) and see if you have any email in Queue.

    Let us know your finding

    Regards,

    Anurag

    Comment

    • Lavish Kumar

      Attached file is the screenshot of Rule.

    • Anurag Mittal

      Lavish, can you make sure your Transactional mailing is in launched state and second thing can you open report Id 2009 ( Mailing Delivery Queue ) and see if you have any email in Queue.

      Let us know your finding

      Regards,

      Anurag

    • Lavish Kumar

      Anurag, you are right. my transaction mailing was NOT launched. I still have not received any email yet as I created a new incident for this test with mailing set as LAUNCHED.

      No record in the report 2009. see screenshot attached

       

    • Anurag Mittal

      Lavish, ideally this steps should work. It may happen that you don't have mailbox configured for this specific interface. Refer this article

    • Ryan

      Lavish - 

      Please try sending a proof of the mailing to yourself - is it properly received?

    • Lavish Kumar

      Hello Anurag & Ryan,

      I do have mailbox setup already. Like I mentioned in my very first post, when I sent out the transactional mailing as proof, then I receive it without any issue. But what I am trying to test needs the mailing to be send from business rule only.

      This exact same business rule works on the production console but currently I am trying to figure out why it is not working on test console.

      any advise?
        

    • Pramod Vasudeva Murthy

      Lavish,

      I was facing the same issue after implementing this it worked fine. See if you can try with it:

      Create a function to send out transactional email and Create a function call in "then" part of "if" condition. Hope it works.

    • Lavish Kumar

      I just receive the survey email via business rule. Let me double check again by creating an another incident to make sure it is working,.

      I will report back the results.

    • Lavish Kumar

      @Pramod, thank you for your advise. I just posted some results above. I am testing again to confirm,

    • Lavish Kumar

      Everything seems to be working now. Thank you everyone for your help :)

    • Lavish Kumar

      Facing a small issue: It seems like many of the transactional mail is being stuck in mailing queue. I did receive 1 or 2 but now every mail is getting stuck. see attached screenshot

      Any way to force the mail to sent?

    • Anurag Mittal

      Glad finally it worked...

      For recent issue, this Article suggest:: If you see any mailings in report 2009 (Mailing Delivery Queue) which have a "scheduled" date in the past, please submit an incident to Customer Care .

    • Lavish Kumar

      Thanks Anurag, is there any way to view the email that is stuck in the queue?

    • Anurag Mittal

      Click on the number that appears on 'Message In queue' column of report Id 2009, that will give you email detail. 

      If you want to send Transactional mail immediately then remove the After +1 minute condition from your rule (make it 0).

    • Lavish Kumar

      Thank you Anurag. I have also contacted customer support for this as if mails are getting stuck, even if I change 1 to 0, mail might stuck again.