Customer Portal

Get Involved. Join the Conversation.

Topic

    Bastiaan van der Kooij
    answers.special_settings forced on answer reports in CP
    Topic posted April 5, 2018 by Bastiaan van der KooijGold Crown: 30,000+ Points, last edited April 5, 2018 
    112 Views, 2 Comments
    Title:
    answers.special_settings forced on answer reports in CP
    Content:

    When doing a minor upgrade to 3.7 I noticed some weird behavior in a report that displays the number of answers per product / subproduct. It turns out that the answers.special_settings filter is enforced on the report when it is rendered in CP without the actual filter defined in the report itself.

    I intentionally removed this filter since it messes up the count and strips duplicate answers from the report.

    Why is this enforced since in the Knowledge Base it still states that you can run a report without it;
    https://cx.rightnow.com/app/answers/detail/a_id/4273/

    Best of course would be to remove that cloudy setting and just expose the join between answers & Products & visibility, so you have all flexibility. But well , let's just start with this.

    Comment

     

    • Bastiaan van der Kooij

      Anyone from Oracle can comment on this?

    • Willie Eide

      I asked around and no one can answer why special_settings needs to be used on the reports in CP.

      There is an article that refers the the fact that all CP reports must contain the special_settings filter. The reasoning is not posted and is likely before my time.