Policy Automation for B2C Service

Get Involved. Join the Conversation.

Topic

    Joe Aravind
    Class Java.lang.NullPointerExceptionAnswered
    Topic posted February 27, 2017 by Joe AravindBlue Ribbon: 750+ Points 
    168 Views, 6 Comments
    Title:
    Class Java.lang.NullPointerException
    Content:

    Hi All,

    i am getting following error while debugging the interview.

    Class Java.lang.NullPointerException

    Please help me to debug the interview. Previously the same interview worked fine. I already have updated java version. i just updated the policy modeling tool. 

    Thanks,

    Joe

    Version:
    OPA
    Image:

    Best Comment

    Brad Tuckett

    Which version of Internet Explorer are you using?  Oracle Policy Modeling has required IE 11 since February 2016 (http://documentation.custhelp.com/euf/assets/devdocs/february2016/PolicyAutomation/en/Default.htm#Guides/Policy_Modeling_User_Guide/Install_OPM.htm) however it is possible that OPM August 2016 still worked on earlier IE versions, whereas the OPM November 2016 release will not work at all with IE 10 or earlier.

    Comment

     

    • Joe Aravind
      672192.PNG (69KB)
    • Paul Howard

      Hi Joe,

      I had the same error, but it was only sporadic and seemed to happen when my PC was under a high load of activity.  Are you still getting this?

      Which version of OPA are you now on? It may be worthwhile raising a ticket to Oracle directly!

      Thanks,

      PAul

    • Brad Tuckett

      Hi Joe,

      Please confirm which version of Oracle Policy Modeling you are using? You also say you just updated OPM - from which version?  Did you ever see this error prior to updating OPM?

      Does this error happen immediately when you debug the interview, or after submitting a particular screen?

      Kind Regards,

      Brad

    • Joe Aravind

      Hi Paul/Brad,

      Thanks for reply. My current version is OPM_Nov2016_v12.2.5.644.0 updated from Aug version. i am still getting the error. Previously i didn't get any error like that. Even i am getting error for example projects. You can open PATH FINDER example project after open the project try to navigate to interview tab by that time itself you will get an error. You may get different errors which likes that i mentioned in my previous post.

      Thanks,

      Joe

    • Brad Tuckett

      Which version of Internet Explorer are you using?  Oracle Policy Modeling has required IE 11 since February 2016 (http://documentation.custhelp.com/euf/assets/devdocs/february2016/PolicyAutomation/en/Default.htm#Guides/Policy_Modeling_User_Guide/Install_OPM.htm) however it is possible that OPM August 2016 still worked on earlier IE versions, whereas the OPM November 2016 release will not work at all with IE 10 or earlier.

    • Joe Aravind

      Hi Brad,

      After upgrading Internet Explorer from IE10 to IE11, OPM working fine. Thanks for your solution.

      Thanks,

      Joe