Visual Builder

Get Involved. Join the Conversation.

Topic

    Vidyasagar Atikam
    Not able see "+ Web Application" in VBCS
    Topic posted June 14, 2019 by Vidyasagar AtikamGreen Ribbon: 100+ Points, last edited June 14, 2019 
    39 Views, 16 Comments
    Title:
    Not able see "+ Web Application" in VBCS
    Content:

    Hi,

    I am new to VBCS and recently got access to https://vbfadev1-faeopsvbcs.builder.test.ocp.oc-test.com/ic/builder/ . After creating a New application, I am not seeing the "+ Web Application"

     

     Is this due to some privilege issue? Whom should I contact in case if you are not right contact.

    Image:

    Comment

     

    • John Ceccarelli

      Something went wrong. You created clean app or imported an app? Try refreshing the window (F5) to see if it comes up. Otherwise try creating a new project and see if the problem is still happening. If neither works I'll file a bug and we can debug. Is this a trial instance?

    • Vidyasagar Atikam

      Thanks John for your response. I tried  creating a clean app in fact tried creating the multiple apps but it is the same issue across other apps. Even I tried refreshing the page. 

    • John Ceccarelli

      Let me look into this

    • John Ceccarelli

      can you export one of these apps and attach it here?

       

    • Vidyasagar Atikam

      Please find the attached file

    • Shay Shmeltzer

      Which browser are you using? You should be using Chrome.

    • Vidyasagar Atikam

      I am using Chrome only.

    • Vidyasagar Atikam

      Hi,

      I can see the "+ Web Application" OR "Web App +" in mac machine chrome browser but same is not visible in windows chrome browser. Chrome browser version  on both Mac and Windows are same.

      It looks like a windows based issue 

       

      Thanks,

       

    • Vidyasagar Atikam

      Tried after clearing the caches and hard refresh (CTL+F5). But no luck. Do we have to install any controls/extensions to support windows chrome browser

      • Shay Shmeltzer

        No special installation is needed.

        If you open the browser's developer tools and look at the console - do you see any errors popping up?

         

    • Vidyasagar Atikam

      Hi,

      I see below errors in developer tools and look at the console:

       

      vbdt/platform/api/application/ApplicationSupport: Application Reputation-1.0 has been activated.
      /ic/builder/design/Reputation/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      vbfadev1-faeopsvbcs.builder.test.ocp.oc-test.com/:1 Uncaught (in promise) Object
      /ic/builder/design/Reputation/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      jsnlog.js:1 vbdt/platform/api/audit/AuditResults: Done traversing auditable objects
      /ic/builder/resources/system/propertystorage/vbcs.components.exchange.url?defaultValue=:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      jsnlog.js:1 vbdt/platform/api/jQueryAdapter: GET /ic/builder/resources/system/propertystorage/vbcs.components.exchange.url?defaultValue= FAILED
      n.cwarn @ jsnlog.js:1
      n.sendLogItemsConsole @ jsnlog.js:1
      i.sendBatch @ jsnlog.js:1
      i.log @ jsnlog.js:1
      e.log @ jsnlog.js:1
      log @ Logger.js:1
      warn @ Logger.js:1
      (anonymous) @ TemplateExchangeComponent.js:2
      c @ jquery.js:1
      fireWith @ jquery.js:1
      p @ jquery.js:1
      jsnlog.js:1 vbdt/platform/api/ce/ComponentExchange: No Component Exchange registered.
      /ic/builder/design/Reputation/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      vbfadev1-faeopsvbcs.builder.test.ocp.oc-test.com/:1 Uncaught (in promise) Object

    • Vidyasagar Atikam

      Hi,

      I created the Web App in Mac machine and opening the same page again in my Windows machine, I see below errors in developer tools/console

      vbdt/platform/api/utils/ManifestUtils: Added 0 package(s) from 0 extension(s).
      jsnlog.js:1 vbdt/platform/api/application/ApplicationSupport: Application Reputation-1.0 has been activated.
      /ic/builder/design/Reputation/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      /ic/builder/?root=application&application=Reputation-1.0&artifact=Welcome:1 Uncaught (in promise) Object
      /ic/builder/design/Reputation/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      jsnlog.js:1 vbdt/platform/api/audit/AuditResults: Done traversing auditable objects
      /ic/builder/resources/system/propertystorage/vbcs.components.exchange.url?defaultValue=:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      jsnlog.js:1 vbdt/platform/api/jQueryAdapter: GET /ic/builder/resources/system/propertystorage/vbcs.components.exchange.url?defaultValue= FAILED
      n.cwarn @ jsnlog.js:1
      n.sendLogItemsConsole @ jsnlog.js:1
      i.sendBatch @ jsnlog.js:1
      i.log @ jsnlog.js:1
      e.log @ jsnlog.js:1
      log @ Logger.js:1
      warn @ Logger.js:1
      (anonymous) @ TemplateExchangeComponent.js:2
      c @ jquery.js:1
      fireWith @ jquery.js:1
      p @ jquery.js:1
      jsnlog.js:1 vbdt/platform/api/ce/ComponentExchange: No Component Exchange registered.
      /ic/builder/design/Reputation/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      /ic/builder/?root=application&application=Reputation-1.0&artifact=Welcome:1 Uncaught (in promise) Object
      jsnlog.js:1 vbdt/app-shell/api/AppShellController: Clearing module cache for vbdt/app-nav/find/Find
      jsnlog.js:1 vbdt/platform/api/application/ApplicationSupport: Application Reputation-1.0 deactivated.
      jsnlog.js:1 vbdt/platform/api/application/ApplicationSupport: Application Wellness-1.0 has been activated.
      /ic/builder/design/Wellness/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      jsnlog.js:1 vbdt/platform/api/audit/AuditResults: Done traversing auditable objects
      /ic/builder/design/Wellness/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      vbfadev1-faeopsvbcs.builder.test.ocp.oc-test.com/:1 Uncaught (in promise) Object
      /ic/builder/design/Wellness/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      vbfadev1-faeopsvbcs.builder.test.ocp.oc-test.com/:1 Uncaught (in promise) Object
      /ic/builder/resources/system/propertystorage/vbcs.components.exchange.url?defaultValue=:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      jsnlog.js:1 vbdt/platform/api/jQueryAdapter: GET /ic/builder/resources/system/propertystorage/vbcs.components.exchange.url?defaultValue= FAILED
      n.cwarn @ jsnlog.js:1
      jsnlog.js:1 vbdt/platform/api/ce/ComponentExchange: No Component Exchange registered.
      /ic/builder/design/Wellness/1.0/resources/storage/?recursive=true&pattern=.%2A:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
      vbfadev1-faeopsvbcs.builder.test.ocp.oc-test.com/:1 Uncaught (in promise) Object

    • Shay Shmeltzer

      Looks like you are using an Oracle Internal server - please post on the Oracle Internal slack channel - #fa-vb-dev

    • Vidyasagar Atikam

      Yes. I posted in both Oracle Internal slack channels - #fa-vb-dev and #visualdev, but no response yet :-(

    • Duncan Mills

      If you are internal to Oracle please do not use this public forum use the available internal resources