Digital Assistant and Mobile

Get Involved. Join the Conversation.

Topic

    Ameur Baccoucha
    build module failed: npm install failed: stderr maxBuffer...
    Topic posted April 12, 2019 by Ameur BaccouchaSilver Medal: 2,000+ Points, tagged Bots, Conversational AI, Virtual Assistant 
    47 Views, 2 Comments
    Title:
    build module failed: npm install failed: stderr maxBuffer exceeded
    Summary:
    I try to upload my package. TGZ to the embeded conatiner but i get an error.
    Content:

    The error that i got is :

    unhandledRejection
    build module failed: npm install failed: stderr maxBuffer exceeded
    BUILDER_BUILD_MODULE_ERROR: build module failed: npm install failed: stderr maxBuffer exceeded
        at Builder.buildModuleForService (/usr/src/app/node_modules/hosted_cc_builder/src/builder.js:89:13)
        at <anonymous>
    [object Promise]

     

    and this is my package.json:

    {
      "name": "mybotapi",
      "version": "1.0.0",
      "description": "amazus bot costum component ",
      "main": "mybotapi.js",
      "dependencies": {
        "body-parser": "^1.15.0",
        "express": "^4.13.4",
        "http-auth": "^3.1.3",
        "joi": "^9.2.0",
        "moment": "^2.16.0",
        "strong-soap": "^1.18.0"
      }
    }

     

     

    Comment

     

    • Rohit Dhamija

      I donot see oracle/bots-node-sdk in your package.json.

       

      Here is a sample package.json

       

      {
        "name": "pwcc_new",
        "version": "1.0.0",
        "description": "",
        "main": "main.js",
        "scripts": {
          "test": "echo \"Error: no test specified\" && exit 1",
          "bots-node-sdk": "bots-node-sdk",
          "help": "npm run bots-node-sdk -- --help",
          "prepack": "npm run bots-node-sdk -- --pack --dry-run",
          "start": "npm run bots-node-sdk -- --service ."
        },
        "keywords": [],
        "author": "",
        "license": "ISC",
        "dependencies": {
          "@oracle/bots-node-sdk": "^2.1.3",
          "request": "^2.88.0"
        },
        "devDependencies": {
          "@oracle/bots-node-sdk": "^2.1.3",
          "express": "^4.16.3"
        }
      }

       

      Here is the article + complete code to deploy on local container https://blogs.oracle.com/mobile/techexchange-tutorial%3a-building-custom-component-services-for-oracle-digital-assistant-in-under-5-minutes-with-oracle-bots-nodejs-sdk .

       

      • Ameur Baccoucha

        hi ,

        Thanks for the reply.

        i did use read the blog and use it and this is my new package.json file, but i still have the same error.

        {
          "name": "NVLCC",
          "version": "1.0.0",
          "description": "",
          "main": "main.js",
          "scripts": {
            "test": "echo \"Error: no test specified\" && exit 1",
            "bots-node-sdk": "bots-node-sdk",
            "help": "npm run bots-node-sdk -- --help",
            "prepack": "npm run bots-node-sdk -- --pack --dry-run",
            "start": "npm run bots-node-sdk -- --service ."
          },
          "keywords": [],
          "author": "",
          "license": "ISC",
          "devDependencies": {
            "@oracle/bots-node-sdk": "^2.1.3",
            "express": "^4.16.3"
          },
          "dependencies": {
            "strong-soap": "^1.18.0"
          }
        }